Fail to set XOM to Non-secure region

Post Reply
workman
Posts: 6
Joined: 16 Oct 2018, 17:39

02 Nov 2018, 09:16

In M2351, I set the non-secure boundary to be 0x40000.
The non-secure region should be 0x10040000 ~ 0x1007ffff.
Then, I set XOM to 0x10060000 and it failed.
Doesn't Non-secure region support XOM in M2351?

SFWU
Posts: 1
Joined: 02 Nov 2018, 09:24

08 Nov 2018, 10:09

XOM base configuration should be APROM physical address which is from 0x0 to 0x80000.

For this case:
The non-secure region is 0x10040000 ~ 0x1007ffff.
set XOM to 0x10060000.

Setting XOM base as 0x10060000 will bill be fialed because 0x10060000 is a logical address for CPU accessing.
If user want to set XOM in 0x10060000, the physical address 0x60000 is the correct setting for XOM base configuration.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest