Nu-Eclipse setup for M480 series string library issues.

Post Reply
Posts: 1
Joined: 20 May 2021, 17:42

24 May 2021, 14:48


I am using M482LGCAE MCU and I am using Development IDE as Eclipse CDT (Mars2) with GNU ARM plugin as provided by nuvoton NuEclipse_V1.01.017 for Linux.
I am having trouble utilising the string library functions like sprintf, strtok, atoi, atof, itoa, ftoa etc.
While debugging I saw that the device reaches to hard fault handler and sometimes moves at the anonymous location.
And the call-stack information shows the crash occurring from the string function.

After searching on internet, for resolving this issue
I tried enabling the linker options:
1. --specs=nano.specs
2. -u _printf_float
3. -u _scanf_float
This did not resolve the issue.
So, I also tried defining stack and heap size in preprocessor like:
1. __STACK_SIZE=25600
2. __HEAP_SIZE=25600
Also tried defining different values here.

This also did not work.
The Nu Eclipse eclipse package provided GCC version 6.3.1.
[gcc version 6.3.1 20170215 (release) [ARM/embedded-6-branch revision 245512] (GNU Tools for ARM Embedded Processors 6-2017-q1-update)]

I also tried utilising the latest arm GCC version 10.2.1.
[gcc version 10.2.1 20201103 (release) (GNU Arm Embedded Toolchain 10-2020-q4-major)]
This helped me to make the sprintf working to some extent.

Can anyone tell me, if there is some other configuration required for running this smoothly?

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest